Написать программу С++ для решения задачи: В парке начали красить скамейки. В первый день
покрасили B скамеек. Во второйпокрасили A% от общего количества скамеек. Осталось покрасить 45 скамеек.Сколько всего скамеек в парке.Ответы на вопрос
Ответ:
Привет, Леха!
Не знаю, как на плюсах, а на шарпе можно попробовать так:
#region task 2
Console.WriteLine();
Console.WriteLine("Task 2");
Console.WriteLine("Please, enter number of benches, painted at 1st day?");
int benches1 = Convert.ToInt32(Console.ReadLine());
Console.WriteLine(String.Concat("Ok, I got it, ", Convert.ToString(benches1), " benches painted at 1st day"));
Console.WriteLine("Please, enter percentage of benches, painted at 2nd day?");
int benches2 = Convert.ToInt32(Console.ReadLine());
Console.WriteLine(String.Concat("Ok, it is clear, ", Convert.ToString(benches2), "% of benches painted at 2nd day"));
Console.WriteLine(String.Concat("Total count of benches in the park:", Convert.ToString(func_Task2(benches1, benches2))));
double func_Task2(int _x, int _y)
{
int res;
res = _x + (_x * Convert.ToInt32(_y/100)) + 45;
return res;
}
#endregion
Объяснение:
Код примитивный, если нужны проверки - добавь сам.
Вот пример программы на C++, которая решает данную задачу:
cpp#include <iostream>
int main() {
int b, a, remaining, total;
std::cout << "Введите количество скамеек, покрашенных в первый день (B): ";
std::cin >> b;
std::cout << "Введите процент (A) от общего количества скамеек, покрашенных во второй день: ";
std::cin >> a;
std::cout << "Введите количество оставшихся скамеек для покраски: ";
std::cin >> remaining;
// Рассчитываем общее количество скамеек в парке
total = (remaining + b) / (a / 100.0);
std::cout << "В парке всего " << total << " скамеек." << std::endl;
return 0;
}
Программа запрашивает количество скамеек, покрашенных в первый день (B), процент от общего количества скамеек, покрашенных во второй день (A), и количество оставшихся скамеек для покраски. Затем она вычисляет общее количество скамеек в парке и выводит результат на экран.
Обратите внимание, что процент (A) вводится как целое число, например, для 50% нужно ввести 50. Результат будет выведен как вещественное число, так как деление может давать нецелочисленные значения.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
