
Напишите программу, в которой объявляется массив из 20 целых чисел, заполняется про помощи датчика
случайных чисел из промежутка [-10, 10] и выводятся на экран элементы этого массива в строку.На языке Паскаль,это очень ВАЖНО!

Ответы на вопрос

Ответ:
---PascalABC.NET 3.6.2 ---
begin
//Создадим переменную A типа List<integer>, задав в конструкторе ёмкость в 20 элементов;
var A : List<integer> := New List<integer>(20);
A.AddRange(SeqGen(A.Capacity, p -> Random(-10, 10))); //Запишем в наш List последовательность, длина которой равна List<T>.Capacity, и каждый элемент в которой генерируется случайно в диапазоне [-10; 10]
A.Println; //Распечатаем в консоль содержимое A
end.
Объяснение:
Заместо стандартного паскалевского массива использован класс List<T> библиотеки .NET Framework, являющийся аналогом обычного массива, но имеющий большее число методов для работы с ним.
А вообще, программа может быть написана в 1 строку:
begin
ArrRandom(20, -10, 10).Println;
end.



// PascalABC.NET
begin
var a := ArrRandom(20, -10, 10);
a.Print
end.



Конечно, вот пример программы на языке Паскаль, который выполняет указанные вами задачи:
pascalprogram RandomArrayExample; var arr: array[1..20] of Integer; i: Integer; begin Randomize; // Инициализация генератора случайных чисел // Заполняем массив случайными числами из промежутка [-10, 10] for i := 1 to 20 do arr[i] := Random(21) - 10; // Выводим элементы массива на экран Write('Массив: '); for i := 1 to 20 do begin Write(arr[i]); if i < 20 then Write(', '); end; Writeln; end.
Этот код создает массив arr
из 20 целых чисел и заполняет его случайными числами в диапазоне от -10 до 10. Затем он выводит элементы массива в строку с разделителями.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili