Вопрос задан 08.07.2023 в 21:16.
Предмет Информатика.
Спрашивает Фёдорова Маша.
Заранее спасибо (PASCAL) Составьте программу, в которой осуществляется ввод целых двузначных
чисел до тех пор, пока их сумма не превысит 1000, подсчитывается и выводится их количество и среднее арифметическое.Ответы на вопрос
Отвечает Кашин Никита.
// PascalABC.NET
begin
var (k, s) := (0, 0);
repeat
var n := ReadInteger;
k += 1;
s += n
until s > 1000;
Print('Количество', k, 'среднее', s/k)
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на Pascal, который реализует описанное вами поведение:
pascalprogram TwoDigitNumbers; var num, sum, count: integer; average: real; begin sum := 0; count := 0; writeln('Введите целые двузначные числа. Для завершения введите число, чтобы сумма превысила 1000.'); repeat write('Введите число: '); readln(num); if (num >= 10) and (num <= 99) then begin sum := sum + num; count := count + 1; end else writeln('Введенное число не является двузначным.'); until sum > 1000; if count > 0 then begin average := sum / count; writeln('Количество введенных чисел: ', count); writeln('Среднее арифметическое: ', average:0:2); end else writeln('Не было введено двузначных чисел.'); end.
Скопируйте этот код в среду разработки Pascal и запустите его. Программа будет ждать ввода двузначных чисел до тех пор, пока сумма введенных чисел не превысит 1000. Затем она выведет количество введенных чисел и их среднее арифметическое.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
