 
Pascal ABC. В файле в столбик записаны целые числа, сколько их – неизвестно. Напишите программу,
которая определяет длину самой длинной цепочки идущих подряд одинаковых чисел и выводит результат в другой файл. Пожалуйста напишите подходящую программу. 10 класс. 0
        0
         0
        0
    Ответы на вопрос
 
        Ответ:
Объяснение:
program zadacha;
var d, o: text;
i, j, k, m, s: integer;
begin
assign(d, 'c:\data.txt');
reset(d);
assign(o, 'c:\output.txt');
rewrite(o);
i := 1;
j := 1;
readln(d, m);
s := m;
while not(eof(d)) do
begin
readln(d, k);
if k = m
then i := i + 1
else
begin
if i > j then
begin
s := m;
j := i
end;
m := k
end;
end;
writeln(o, 'Число: ', s, ', длина цепочки: ', i);
close(d);
close(o)
end.
 0
                    0
                     0
                    0
                 
            Конечно, вот пример программы на языке Pascal ABC, который читает целые числа из файла, определяет длину самой длинной цепочки идущих подряд одинаковых чисел и записывает результат в другой файл:
pascalprogram LongestSequence; var inputFile, outputFile: text; currentNum, prevNum, maxSequenceLength, currentSequenceLength: integer; begin // Открываем файлы для чтения и записи assign(inputFile, 'input.txt'); assign(outputFile, 'output.txt'); reset(inputFile); rewrite(outputFile); // Инициализируем переменные maxSequenceLength := 0; currentSequenceLength := 0; if not eof(inputFile) then read(inputFile, prevNum); // Читаем числа из файла while not eof(inputFile) do begin read(inputFile, currentNum); if currentNum = prevNum then begin currentSequenceLength := currentSequenceLength + 1; if currentSequenceLength > maxSequenceLength then maxSequenceLength := currentSequenceLength; end else currentSequenceLength := 0; prevNum := currentNum; end; // Закрываем файлы close(inputFile); close(outputFile); // Записываем результат в файл rewrite(outputFile); write(outputFile, maxSequenceLength); close(outputFile); end.
Программа открывает файл для чтения, последовательно сравнивает текущее число с предыдущим, подсчитывает длину текущей последовательности одинаковых чисел и обновляет максимальную длину, если необходимо. По окончанию чтения, она записывает результат в выходной файл. Не забудьте создать файлы input.txt с входными числами и output.txt для записи результата перед запуском программы.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			