Вопрос задан 08.07.2023 в 05:59.
Предмет Информатика.
Спрашивает Бескровный Максим.
На языке программирования написать программу, используя Оператор Условия: Численность населения
г. Берлин составляет около 3620000 человек, г. Мюнхен имеет население около 1360000 человек. При произвольном наборе чисел с клавиатуры , вывести на экран город Германии (Берлин или Мюнхен) или словосочетание «другой город».Ответы на вопрос
Отвечает Муратова Айгерим.
var
a, b: integer;
begin
Readln(a);
Begin
if a = 3620000 then
Write('Берлин') end;
begin
if a = 1360000 then
Write('Мюнхен') end;
End.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Python, который выполняет описанную вами задачу:
python# Задаем численность населения городов
population_berlin = 3620000
population_munich = 1360000
# Ввод числа с клавиатуры
input_population = int(input("Введите численность населения: "))
# Проверяем, к какому городу ближе введенное значение численности населения
if abs(input_population - population_berlin) < abs(input_population - population_munich):
print("Город: Берлин")
elif abs(input_population - population_munich) < abs(input_population - population_berlin):
print("Город: Мюнхен")
else:
print("Другой город")
Пример использования:
makefileВведите численность населения: 1500000
Город: Мюнхен
makefileВведите численность населения: 3000000
Город: Берлин
Введите численность населения: 2000000 Другой город
Вы можете скопировать этот код в среду программирования Python и запустить, чтобы увидеть, как он работает.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
