Вопрос задан 08.07.2023 в 03:06.
Предмет Информатика.
Спрашивает Быков Виктор.
Составьте программу для Pascal Определить, сколько букв содержит самое длинное слово во введенной
строке символов.Входные данныеНа вход программе подается строка, состоящая не более чем из 255 символов. Слова разделяются одним или несколькими пробелами.Выходные данныеВыведите искомое число.Примерывходные данныеabcd efвыходные данные4Ответы на вопрос
Отвечает Луньков Никита.
А нет всё-таки по информатике
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Привет! Вот программа на языке Pascal, которая решает задачу, которую ты описал:
pascalprogram LongestWordLength; const MAX_LENGTH = 255; var inputString: string; longestLength, currentLength, i: integer; begin readln(inputString); longestLength := 0; currentLength := 0; for i := 1 to Length(inputString) do begin if inputString[i] <> ' ' then begin currentLength := currentLength + 1; if currentLength > longestLength then longestLength := currentLength; end else currentLength := 0; end; writeln(longestLength); end.
Программа считывает введенную строку с помощью readln и затем выполняет цикл по каждому символу строки. Если символ не является пробелом, программа увеличивает currentLength на 1. Если текущая длина больше longestLength, то longestLength обновляется.
Когда программа встречает пробел, она сбрасывает currentLength обратно в 0. В результате после обработки всей строки в longestLength будет храниться длина самого длинного слова.
Наконец, программа выводит longestLength с помощью writeln.
Надеюсь, эта программа поможет тебе решить задачу! Если у тебя возникнут еще вопросы, не стесняйся спрашивать.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 36
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
