Вопрос задан 11.07.2018 в 22:08.
Предмет Информатика.
Спрашивает Новиков Артур.
Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём все
элементы, превышающие данное число Z, этим числом. Вывести на экран полученный массив и количество замен. Протестировать программу на следующих исходных данных: а) Z=10 Массив: 1,2 2,6 3 -4,5 11 10,2 3,2 87 -15 б) Z=-2 Массив: 0 -3,1 11 -7,9 -2,1 -1,9 4Ответы на вопрос
Отвечает Тупиков Сергей.
const
n=10;
var
a:array [1..n] of real;
z,i,k:integer;
begin
for i:=1 to n do
begin
write ('A[',i,'] = ');readln(a[i]);
end;
write ('Z = ');readln(z);
for i:=1 to n do
if a[i]>z then begin
a[i]:=z;
k:=k+1;
end;
for i:=1 to n do
if frac(a[i])=0 then write (a[i]:0:0,' ') else write (a[i]:0:1,' ');
writeln ('Kol-vo zamen: ',k);
readln;
end.
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
