Вопрос задан 07.07.2023 в 23:59.
Предмет Информатика.
Спрашивает Амирсеит Данияр.
ПОМОГИТЕ, ПОЖАЛУЙСТА, ПАСКАЛЬ Иван Васильевич пришел на рынок и решил купить два арбуза: один для
себя, а другой для тещи. Понятно, что для себя нужно выбрать арбуз потяжелей, а для тещи полегче. Но вот незадача: арбузов слишком много и он не знает как же выбрать самый легкий и самый тяжелый арбуз? Помогите ему! Входные данные В первой строке входного файла INPUT.TXT задано одно число N – количество арбузов. Вторая строка содержит N чисел, записанных через пробел. Здесь каждое число – это масса соответствующего арбуза. Все числа натуральные и не превышают 30000. Выходные данные В выходной файл OUTPUT.TXT нужно вывести два числа через пробел: массу арбуза, который Иван Васильевич купит теще и массу арбуза, который он купит себе. INPUT.TXT OUTPUT.TXT 5 1 9 5 1 6 5 9Ответы на вопрос
Отвечает Телещак Анастасия.
// PascalABC.NET, запускать по Shift + F9
begin
Assign(input, 'INPUT.TXT');
var n := ReadlnInteger;
var a := ReadArrInteger(n);
Assign(output, 'OUTPUT.TXT');
Print(a.Min, a.Max);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи вам потребуется найти самый легкий и самый тяжелый арбуз в списке. Можно сделать это, перебирая все числа и сохраняя текущий минимум и максимум.
Вот пример решения на языке Паскаль:
pascalprogram Arbuzy; var N, i, weight, minWeight, maxWeight: integer; begin assign(input, 'INPUT.TXT'); assign(output, 'OUTPUT.TXT'); reset(input); rewrite(output); // Считываем количество арбузов readln(N); // Инициализируем переменные для минимального и максимального веса minWeight := 30001; maxWeight := 0; // Читаем веса арбузов и обновляем минимальный и максимальный вес for i := 1 to N do begin read(weight); if weight < minWeight then minWeight := weight; if weight > maxWeight then maxWeight := weight; end; // Выводим результат writeln(minWeight, ' ', maxWeight); close(input); close(output); end.
После выполнения программы, результат будет записан в файл OUTPUT.TXT. В данном случае ответ будет 1 9, что соответствует массе арбуза для тещи (1) и массе арбуза для Ивана Васильевича (9).
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 18
Информатика 34
Информатика 19
Информатика 26
Информатика 20
Информатика 33
Информатика 31
Информатика 21
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
