Написать программу на C++ Дана матрицы из 3 строк и 7 столбцов. Рассматривая содержание каждого
элемента столбца как длину стороны треугольника, отпечатать номера столбцов, которыми заданы равнобедренные треугольники, и число таких столбцов.Ответы на вопрос
#include <iostream>
#include <vector>
using namespace std;
bool ok1(int a, int b, int c){
return (a+b > c && a+c > b && b+c > a) && min(a,min(b,c)) > 0;
}
bool ok2(int a, int b, int c){
return ok1(a,b,c) && (a == b || a == c || b == c);
}
signed main(){
const int n = 3, m = 7;
int arr[n][m];
for(int i = 0; i < n; i++)
for(int j = 0; j < m; j++)
cin >> arr[i][j];
vector<int> ans;
for(int j = 0; j < m; j++)
if(ok2(arr[0][j],arr[1][j],arr[2][j]))
ans.push_back(j+1);
cout << ans.size() << "\n";
for(auto i: ans)
cout << i << " ";
}
Конечно, вот пример программы на C++, которая выполняет указанную задачу:
cpp#include <iostream>
#include <cmath>
// Функция для проверки, является ли треугольник равнобедренным
bool isIsoscelesTriangle(double a, double b, double c) {
return (a == b) || (b == c) || (a == c);
}
int main() {
const int rows = 3;
const int cols = 7;
double matrix[rows][cols] = {
{3.0, 4.0, 5.0, 6.0, 7.0, 8.0, 9.0},
{5.0, 5.0, 6.0, 7.0, 8.0, 9.0, 10.0},
{2.0, 3.0, 4.0, 4.0, 3.0, 2.0, 1.0}
};
int countIsosceles = 0; // Счетчик равнобедренных треугольников
for (int j = 0; j < cols; ++j) {
// Проверяем каждый столбец на равнобедренные треугольники
if (isIsoscelesTriangle(matrix[0][j], matrix[1][j], matrix[2][j])) {
std::cout << "Столбец " << j + 1 << " задает равнобедренный треугольник." << std::endl;
++countIsosceles;
}
}
std::cout << "Всего равнобедренных треугольников: " << countIsosceles << std::endl;
return 0;
}
Программа создает матрицу из 3 строк и 7 столбцов, в которой каждый элемент представляет длину стороны треугольника. Затем она проверяет каждый столбец на то, задает ли он равнобедренный треугольник, и выводит информацию о таких столбцах и общее количество равнобедренных треугольников.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
