Вопрос задан 07.07.2023 в 13:41. Предмет Информатика. Спрашивает Трушковская Анастасия.

Помогите пожалуйста!!! Паскаль Дан текст. Найти максимальное из имеющихся в нём чисел.

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шляхецкий Илья.
Бесконечно !!!!!!!!!!!!!!!!!!!!!!!!!!!!
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам написать программу на языке Паскаль, которая найдет максимальное число в данном тексте. Вот пример кода:

pascal
program FindMaxNumberInText; uses SysUtils, StrUtils; function ExtractNumbers(const S: string): TArray<Integer>; var i, j, numCount: Integer; numStr: string; begin SetLength(Result, 0); i := 1; numCount := 0; while i <= Length(S) do begin numStr := ''; while (i <= Length(S)) and (not CharInSet(S[i], ['0'..'9'])) do Inc(i); while (i <= Length(S)) and CharInSet(S[i], ['0'..'9']) do begin numStr := numStr + S[i]; Inc(i); end; if numStr <> '' then begin SetLength(Result, numCount + 1); Result[numCount] := StrToInt(numStr); Inc(numCount); end; end; end; function FindMaxNumber(const numbers: TArray<Integer>): Integer; var i: Integer; begin Result := Integer.MinValue; // Начальное значение для максимального числа for i := 0 to Length(numbers) - 1 do begin if numbers[i] > Result then Result := numbers[i]; end; end; var inputText: string; numbers: TArray<Integer>; maxNumber: Integer; begin WriteLn('Введите текст:'); ReadLn(inputText); numbers := ExtractNumbers(inputText); if Length(numbers) > 0 then begin maxNumber := FindMaxNumber(numbers); WriteLn('Максимальное число в тексте:', maxNumber); end else WriteLn('В тексте не найдено чисел.'); ReadLn; end.

Скопируйте данный код в среду разработки для Паскаля (например, Lazarus) и выполните его. Программа попросит вас ввести текст, затем выведет максимальное число из него.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос