Вопрос задан 11.07.2018 в 15:01.
Предмет Информатика.
Спрашивает Кузьменко Николай.
Составьте программу вычисления 1+2+4+8+...+2(в 10 степени)
Ответы на вопрос
Отвечает Андреевна Елена.
Pascal abc;
var a,b,sum:longint;
begin
b:=1;
for a:=0 to 10 do begin
sum:=sum+b;
b:=b*2;
end;
writeln('сумма чисел от 2^0 до 2^10 sum=',sum);
end.
С++;
#include <iostream>
using namespace std;
int main()
{
int sum=0,b=1;
for(int a=0;a<=10;a++)
{
sum=sum+b;
b=b*2;
}
cout<<"сумма чисел от 2^0 до 2^10 sum = "<< sum;
return 0;
}
Топ вопросов за вчера в категории Информатика
Информатика 17
Информатика 40
Информатика 27
Информатика 61
Информатика 10
Информатика 13
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
