Вопрос задан 07.07.2023 в 11:33.
Предмет Информатика.
Спрашивает Полярная Ульяна.
Помогите пожежуто 1. Создать программу, которая, запросив сторону квадрата, выдает, чему равен
его периметр и площадь. 2. Создать программу, которая, запросив целое двухзначное число, выдает, чему равна сумма и произведение цифр этого числа. Паскаль.Ответы на вопрос
Отвечает Пархоменко Александр.
Ответ:
Первая программа:
program p1;
var
a,p,s : integer;
begin
write('Введите сторону квадрата:');
readln(a);
p := a * 4;
s := a * a;
writeln('Периметр квадрата = ', p);
writeln('Площадь квадрата = ', s);
readln;
end.
Вторая программа:
program p2;
var
a,p,s,pow : integer;
begin
write('Введите число: ');
readln(a);
p := a mod 10;
s := (a div 10) mod 10;
pow := p * s;
writeln('Произведение цифр числа: ', pow);
readln;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот примеры программ на языке Pascal для решения ваших задач:
Программа 1: Вычисление периметра и площади квадрата
pascalprogram SquareProperties; var side, perimeter, area: real; begin writeln('Введите сторону квадрата: '); readln(side); perimeter := 4 * side; area := side * side; writeln('Периметр квадрата: ', perimeter:0:2); writeln('Площадь квадрата: ', area:0:2); end.
Программа 2: Вычисление суммы и произведения цифр двухзначного числа
pascalprogram DigitOperations; var number, digit1, digit2, sum, product: integer; begin writeln('Введите двухзначное число: '); readln(number); if (number < 10) or (number > 99) then begin writeln('Введено некорректное число. Пожалуйста, введите двухзначное число.'); exit; end; digit1 := number div 10; digit2 := number mod 10; sum := digit1 + digit2; product := digit1 * digit2; writeln('Сумма цифр числа: ', sum); writeln('Произведение цифр числа: ', product); end.
Обе программы запросят вас ввести необходимые данные и выведут результаты расчетов.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
