
Запрограммировать решение задач на языке Паскаль. 1) Программа предлагает вычислить выражение
12*6 - 13*3 и ввести ответ с клавиатуры. Если ответ верен, то вывести на экран фразу "Правильно!", иначе - вывести "Ошибка в расчётах!" 2) Программа запрашивает возраст. Если введён воздаст до 14 лет, то программа выводит "Вы ещё не получили паспорт!, иначе - программа выводит "Пасторт вами получен!". 3*) Составьте программу "Покупка". В магазине продают три вида мороженого: Эскимо по цене 50 рублей, фруктовый лёд по цене 30 рублей и пломбир по цене 48 рублей. Программа запращивает "Какое мороженое хотите купить?". Пользователь вводит название сорта мороженого. В ответ на экран выводится стоимость мороженого.

Ответы на вопрос

Ответ:
Задача 1)
var a: real;
begin
writeln('Вычислите выражение 12*6 - 13*3');
readln(a);
if a=33 then writeln('Правильно') else writeln('Ошибка в расчётах');
end.
Задача 2)
var a: real;
begin
writeln('Сколько вам лет?');
readln(a);
if a<14 then writeln('Вы ещё не получили паспорт!') else writeln('Паспорт вами получен!');
end.
Задача 3)
program pocupka;
var a: string;
begin
writeln('Какое мороженное вы хотите купить эскимо, фруктовый лёд или пломбир?');
readln(a);
if a='эскимо' then writeln('50 рублей');
if a='фруктовый лёд' then writeln('30 рублей');
if a='пломбир' then writeln('48 рублей');
end.
Объяснение:



Вот решение задач на языке Паскаль:
- Программа для вычисления выражения и проверки ответа:
pascalprogram Task1; var answer: Integer; begin WriteLn('Вычислите выражение 12 * 6 - 13 * 3'); Write('Введите ответ: '); ReadLn(answer); if answer = 42 then WriteLn('Правильно!') else WriteLn('Ошибка в расчётах!'); end.
- Программа для проверки возраста и вывода сообщения:
pascalprogram Task2; var age: Integer; begin Write('Введите возраст: '); ReadLn(age); if age < 14 then WriteLn('Вы ещё не получили паспорт!') else WriteLn('Паспорт вами получен!'); end.
- Программа для выбора мороженого и вывода его стоимости:
pascalprogram Task3; var iceCream: string; price: Integer; begin Write('Какое мороженое хотите купить? '); ReadLn(iceCream); if iceCream = 'Эскимо' then price := 50 else if iceCream = 'фруктовый лёд' then price := 30 else if iceCream = 'пломбир' then price := 48 else begin WriteLn('Неверное название мороженого!'); Exit; // Прерываем выполнение программы end; WriteLn('Стоимость ', iceCream, ' составляет ', price, ' рублей.'); end.
Обратите внимание, что в третей программе я использовал строчные символы для названий мороженого, чтобы быть более гибким. Если пользователь введёт название с заглавными буквами, программа все равно будет работать.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili