Вопрос задан 07.07.2023 в 01:28.
Предмет Информатика.
Спрашивает Калабина Света.
Напишите программу, которая в последовательности натуральных чисел находит минимальное нечетное
трехзначное число или сообщает, что таких чисел нет. На вход программы подаются количество чисел n, а дальше сами числа x. Программа должна вывести минимальное четное трехзначное число или вывести NO, если таких чисел в последовательности нет. PASCAL ОЧЕНЬ СРОЧНО!!!!!!Ответы на вопрос
Отвечает Васильцов Илья.
Ответ:
var i, min, x, n:Integer;
begin
min:=1000;
readln(n);
for i := 1 to n do
begin
readln(x);
if (x < min) and (x mod 2 <> 0) and (x>=100) and (x<1000) then
min:=x;
end;
if min = 1000 then
writeln('NO')
else
writeln(min);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на Pascal, которая решает данную задачу:
pascalprogram MinOddThreeDigit; var n, i, x, minOdd: integer; found: boolean; begin minOdd := 1000; // Инициализируем переменную значением, которое гарантированно больше любого трехзначного числа found := false; write('Введите количество чисел: '); readln(n); for i := 1 to n do begin write('Введите число ', i, ': '); readln(x); if (x > 99) and (x < 1000) and (x mod 2 <> 0) and (x < minOdd) then begin minOdd := x; found := true; end; end; if found then writeln('Минимальное нечетное трехзначное число: ', minOdd) else writeln('NO'); end.
Скопируйте этот код в среду разработки Pascal, например, в Free Pascal, и запустите программу. Она запросит у вас количество чисел, затем будет поочередно запрашивать сами числа и выведет минимальное нечетное трехзначное число или "NO", если таких чисел нет.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
