
Вопрос задан 06.07.2023 в 14:29.
Предмет Информатика.
Спрашивает Кузьмин Андрей.
РЕШИТЬ В ПРОГРАММЕ ПАСКАЛЬ Напишите программу, которая в последовательности натуральных чисел
определяет сумму чисел, кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5

Ответы на вопрос

Отвечает Лотайчук Алина.
Ответ:
Объяснение:
var n,i,a,s:integer;
begin
write('n = ');
readln(n);
s:=0;
writeln('Введите ',n,' чисел:');
for i:=1 to n do
begin
read(a);
if a mod 5 = 0 then s:=s+a;
end;
writeln('s = ',s);
end.
Пример:
n = 6
Введите 6 чисел:
12 45 84 37 10 51
s = 55



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на Pascal, которая решает данную задачу:
pascalprogram SumOfMultiples; var n, i, num, sum: integer; begin writeln('Введите количество чисел в последовательности:'); readln(n); sum := 0; writeln('Введите числа:'); for i := 1 to n do begin readln(num); if num mod 5 = 0 then sum := sum + num; end; writeln('Сумма чисел, кратных 5, равна: ', sum); end.
Сначала программа запрашивает количество чисел в последовательности. Затем она входит в цикл, где пользователь вводит каждое число последовательности. Если число кратно 5, то оно добавляется к сумме. По завершению цикла выводится сумма чисел, кратных 5.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 566

Информатика 25

Информатика 22

Информатика 27

Информатика 34

Информатика 58

Информатика 63

Информатика 23
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili