
Помогите пожалуйста, паскаль. В последовательности целых чисел определить, каких чисел больше:
положительных или отрицательных. Количество чисел в последовательности НЕ известно, ввод заканчивается числом 0

Ответы на вопрос

Ответ:
--- PascalABC.NET 3.6.2 ---
begin
var (pos, neg) := (0, 0);
ReadSeqIntegerWhile(p -> p <> 0)
.ForEach(p -> begin
if p >= 0 then pos += 1 else neg += 1;
end);
if pos > neg then println('Sequence contains more positive numbers') else
if neg < pos then println('Seqnuece contains more negative numbers') else println('Sequence contains equal count of positive and negative numbers');
end.



Конечно, я помогу вам написать программу на Pascal, которая определит, сколько положительных и сколько отрицательных чисел в последовательности, завершающейся числом 0. Вот пример такой программы:
pascalprogram CountPosNeg; var num, positiveCount, negativeCount: Integer; begin positiveCount := 0; negativeCount := 0; repeat Write('Введите число (для завершения введите 0): '); ReadLn(num); if num > 0 then positiveCount := positiveCount + 1 else if num < 0 then negativeCount := negativeCount + 1; until num = 0; WriteLn('Количество положительных чисел: ', positiveCount); WriteLn('Количество отрицательных чисел: ', negativeCount); end.
Скопируйте этот код в вашу среду разработки Pascal (например, Lazarus) и выполните программу. Она будет последовательно запрашивать числа у пользователя до тех пор, пока не будет введено число 0, и затем выведет количество положительных и отрицательных чисел в последовательности.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili