Вопрос задан 05.07.2023 в 13:18.
Предмет Информатика.
Спрашивает Макарова Анжелика.
Pascal Написать программу, которая для заданного при вводе исходных данных целочисленного
одномерного массива А из m элементов (m<=200), вычисляет произведение положительных элементов и произведение отрицательных элементов или сообщает, что элементов такого вида нет. ( m задается при вводе исходных данных).Ответы на вопрос
Отвечает Иваровская Ксюша.
Ответ:
- begin
- var a := ReadArrInteger(ReadInteger('n:'));
- Println('Положительных:', a.Any(x->x>0)?a.Product(x->x>0?x:1).ToString:'нет');
- Println('Отрицательных:', a.Any(x->x<0)?a.Product(x->x<0?x:1).ToString:'нет');
- end.
Пример работы:

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Pascal, которая решает данную задачу:
pascalprogram CalculateProducts; const MaxSize = 200; var A: array[1..MaxSize] of integer; m, i: integer; positiveProduct, negativeProduct: longint; positiveCount, negativeCount: integer; begin writeln('Введите количество элементов m (не более ', MaxSize, '): '); readln(m); if (m <= 0) or (m > MaxSize) then begin writeln('Некорректное значение m.'); exit; end; positiveProduct := 1; negativeProduct := 1; positiveCount := 0; negativeCount := 0; writeln('Введите элементы массива A:'); for i := 1 to m do begin readln(A[i]); if A[i] > 0 then begin positiveProduct := positiveProduct * A[i]; positiveCount := positiveCount + 1; end else if A[i] < 0 then begin negativeProduct := negativeProduct * A[i]; negativeCount := negativeCount + 1; end; end; if (positiveCount = 0) and (negativeCount = 0) then writeln('В массиве нет ни положительных, ни отрицательных элементов.') else begin writeln('Произведение положительных элементов: ', positiveProduct); writeln('Произведение отрицательных элементов: ', negativeProduct); end; end.
Программа позволяет ввести количество элементов массива m, а затем поочередно ввести значения элементов. После этого программа вычисляет произведение положительных элементов и произведение отрицательных элементов, либо выводит сообщение о том, что таких элементов нет.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
