Вопрос задан 05.07.2023 в 11:07.
Предмет Информатика.
Спрашивает Лесбекова Амина.
Напишите программу сортировки массива строк по убыванию длины (на c++).Заранее спасибо
Ответы на вопрос
Отвечает Васильева Александра.
#include <iostream>
#include <vector>
using namespace std;
bool comp(string s1, string s2){
return s1.length() > s2.length();
}
signed main() {
int n;
cin >> n;
vector<string> a(n);
for(auto &i: a)
cin >> i;
sort(a.begin(),a.end(),comp);
for(auto &i:a)
cout << i << ' ';
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на C++, которая сортирует массив строк по убыванию длины с использованием алгоритма сортировки пузырьком:
cpp#include <iostream>
#include <string>
#include <vector>
void bubbleSortDescendingLength(std::vector<std::string> &arr) {
int n = arr.size();
for (int i = 0; i < n - 1; ++i) {
for (int j = 0; j < n - i - 1; ++j) {
if (arr[j].length() < arr[j + 1].length()) {
std::swap(arr[j], arr[j + 1]);
}
}
}
}
int main() {
std::vector<std::string> strings = {"apple", "banana", "cherry", "date", "elderberry"};
std::cout << "Original array:" << std::endl;
for (const auto &s : strings) {
std::cout << s << " ";
}
std::cout << std::endl;
bubbleSortDescendingLength(strings);
std::cout << "Array sorted in descending order of length:" << std::endl;
for (const auto &s : strings) {
std::cout << s << " ";
}
std::cout << std::endl;
return 0;
}
Просто замените массив strings на ваш собственный массив строк. Этот код использует алгоритм сортировки пузырьком для сортировки строк в массиве по убыванию длины.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
