 
Вопрос задан 05.07.2023 в 10:33.
Предмет Информатика.
Спрашивает Дорошенко Родион.
Составить программу на C++ для решения следующей задачи. Дан массив А, состоящий из 10
действительных чисел. Обменять местами минимальный и последний элемент массива. Массив заполнить с клавиатуры и вывести на экран. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Жумабеков Ерасыл.
                
    #include <iostream>
#include <vector>
using namespace std;
void swap(int *a, int *b){
int temp = *a;
*a = *b;
*b = temp;
}
signed main() {
const int n = 10;
vector<int> a(n);
int mx = -INT_MAX, mn = INT_MAX, i = 0, j = 0;
for(int k = 0; k < n; k++){
cin >> a[k];
if(a[k] > mx){mx = a[k]; i = k;}
if(a[k] < mn){mn = a[k], j = k;}
}
swap(a[i],a[j]);
for(auto &i:a)
cout << i << " ";
}
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно, вот программа на C++, которая решает данную задачу:
cpp#include <iostream>
int main() {
    const int arraySize = 10;
    double arr[arraySize];
    // Ввод элементов массива с клавиатуры
    std::cout << "Введите " << arraySize << " действительных чисел:\n";
    for (int i = 0; i < arraySize; ++i) {
        std::cin >> arr[i];
    }
    // Поиск минимального элемента и его индекса
    double minElement = arr[0];
    int minIndex = 0;
    for (int i = 1; i < arraySize; ++i) {
        if (arr[i] < minElement) {
            minElement = arr[i];
            minIndex = i;
        }
    }
    // Обмен минимального элемента с последним
    double temp = arr[minIndex];
    arr[minIndex] = arr[arraySize - 1];
    arr[arraySize - 1] = temp;
    // Вывод массива на экран
    std::cout << "Измененный массив:\n";
    for (int i = 0; i < arraySize; ++i) {
        std::cout << arr[i] << " ";
    }
    return 0;
}
Программа позволяет вам ввести 10 действительных чисел, находит минимальное число и обменивает его местами с последним элементом массива. Затем выводит измененный массив на экран.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			