Вопрос задан 05.07.2023 в 09:21.
Предмет Информатика.
Спрашивает Титов Егор.
Написать программу на С++, которая: -предлагает пользователю ввести предложение, -считывает
введенную строку, -предлагает пользователю ввести символ, -считывает введенный символ, -добавляет символ пользователя после каждого пробела во введенной ранее строке -выводит результатОтветы на вопрос
Отвечает Поталай Ника.
Ответ:
#include <iostream>
int main() {
std::string str;
char n;
std::cout << "Input your string: ";
getline(std::cin, str);
std::cin.clear();
std::cout << "Input your character: ";
std::cin >> n;
for (int i = 0; i < str.size(); ++i) {
if (str[i] == ' ')
str.insert(i + 1, 1, n);
}
std::cout << str << "\n";
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на C++, которая выполняет описанные вами шаги:
cpp#include <iostream>
#include <string>
int main() {
// Предложение введенное пользователем
std::string sentence;
std::cout << "Введите предложение: ";
std::getline(std::cin, sentence);
// Символ, который нужно добавить после каждого пробела
char symbol;
std::cout << "Введите символ для добавления: ";
std::cin >> symbol;
std::cin.ignore(); // Очистка буфера после считывания символа
// Проход по строке и добавление символа после каждого пробела
std::string modifiedSentence;
for (char c : sentence) {
modifiedSentence += c;
if (c == ' ') {
modifiedSentence += symbol;
}
}
// Вывод результата
std::cout << "Результат: " << modifiedSentence << std::endl;
return 0;
}
Скопируйте этот код в файл с расширением .cpp, скомпилируйте его с использованием компилятора C++, и запустите полученный исполняемый файл. Программа попросит вас ввести предложение и символ, который вы хотите добавить после каждого пробела, а затем выведет результат с модифицированной строкой.
Похожие вопросы
Информатика 76
Информатика 93
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
