Вопрос задан 05.07.2023 в 06:28.
Предмет Информатика.
Спрашивает Саласюк Саша.
Помогите написать пожалуйста программу в Паскале Двумерные массивы 1) Дана целочисленная
прямоугольная матрица. Определить сумму элементов тех строк, которые содержат хотя бы один отрицательный элемент. 2) Определите количество строк в матрице, в которых числа принадлежат отрезку [a,b].Ответы на вопрос
Отвечает Арефьев Александр.
PascalABC.NET
Ответ:
- begin
- var m := MatrRandom(5, 8, -99, 99).Print;
- m.Rows.Where(r -> r.Any(x -> x<0)).PrintLines(r -> r.Sum);
- var (a, b) := ReadInteger2('Введите a, b:');
- m.Rows.Count(r -> r.All(x -> x in a..b)).Print
- end.
Пример работы:

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот две программы на Паскале для решения ваших задач.
- Дана целочисленная прямоугольная матрица. Определить сумму элементов тех строк, которые содержат хотя бы один отрицательный элемент.
pascalprogram SumOfRows; const MaxRows = 100; MaxCols = 100; var matrix: array[1..MaxRows, 1..MaxCols] of Integer; numRows, numCols: Integer; row, col: Integer; sum: Integer; begin { Ввод размеров матрицы } Write('Введите количество строк: '); ReadLn(numRows); Write('Введите количество столбцов: '); ReadLn(numCols); { Ввод элементов матрицы } WriteLn('Введите элементы матрицы:'); for row := 1 to numRows do begin for col := 1 to numCols do begin Write('Элемент [', row, ', ', col, ']: '); ReadLn(matrix[row, col]); end; end; { Вычисление суммы строк } WriteLn('Сумма элементов строк с отрицательными элементами:'); for row := 1 to numRows do begin sum := 0; for col := 1 to numCols do begin if matrix[row, col] < 0 then begin sum := sum + matrix[row, col]; end; end; if sum <> 0 then begin WriteLn('Строка ', row, ': ', sum); end; end; ReadLn; end.
- Определите количество строк в матрице, в которых числа принадлежат отрезку [a, b].
pascalprogram CountRowsInRange; const MaxRows = 100; MaxCols = 100; var matrix: array[1..MaxRows, 1..MaxCols] of Integer; numRows, numCols: Integer; row, col: Integer; a, b: Integer; count: Integer; begin { Ввод размеров матрицы } Write('Введите количество строк: '); ReadLn(numRows); Write('Введите количество столбцов: '); ReadLn(numCols); { Ввод элементов матрицы } WriteLn('Введите элементы матрицы:'); for row := 1 to numRows do begin for col := 1 to numCols do begin Write('Элемент [', row, ', ', col, ']: '); ReadLn(matrix[row, col]); end; end; { Ввод границ отрезка } Write('Введите значение a: '); ReadLn(a); Write('Введите значение b: '); ReadLn(b); { Подсчет количества строк в заданном диапазоне } count := 0; for row := 1 to numRows do begin for col := 1 to numCols do begin if (matrix[row, col] >= a) and (matrix[row, col] <= b) then begin count := count + 1; Break
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 22
Информатика 36
Информатика 60
Информатика 2166
Информатика 10
Информатика 571
Информатика 49
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
