Вопрос задан 05.07.2023 в 04:40. Предмет Информатика. Спрашивает Самарская Ангелина.

1.Написать программу, которая вычисляет сумму первых n членов ряда: 1+1/2+1/3+… Количество

суммируемых членов ряда вводит пользователь 2.) Напишите программу, которая выводит на дисплей следующий график: ********* *** ** * ** *** **** ***** 3.) Напишите программу, которая выводит на экран изображение шахматной доски. Черные клетки отображать "звездочкой", белые — “#”. Рекомендуемый вид экрана во время выполнения программы приведен #*#*#*#* *#*#*#*# #*#*#*#* *#*#*#*# #*#*#*#* *#*#*#*# #*#*#*#* *#*#*#*# Писать на python, даю 50 баллов
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Котова Лена.

1)

n = int(input("Введите количество чисел в ряду >>> "))

summ = 0

for i in range(1, n+1, 1):

   summ += 1/i

print("Сумма ряда <<<", summ)

2)

n = int(input("Введите размер >>> "))

for i in range(n, 0, -1):

   print("*"*i)

for i in range(2, n + 1, 1):

   print("*"*i)

3)

n = int(input("Введите размер >>> "))

firstRow = "#*"*(n//2) + "#"*(n % 2)+"\n"

secondRow = "*#"*(n//2) + "*"*(n % 2)+"\n"

print((firstRow+secondRow)*(n//2)+firstRow*(n % 2))

============

Не забывайте нажать "Спасибо", поставить оценку и, если ответ удовлетворил, то выберите его как "Лучший"

Бодрого настроения и добра!

Успехов в учебе!




0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Разумеется! Ниже приведены программы на языке Python для выполнения каждой из задач.

Задача 1: Вычисление суммы первых n членов ряда

python
def calculate_series_sum(n): sum = 0 for i in range(1, n + 1): sum += 1 / i return sum n = int(input("Введите количество суммируемых членов ряда: ")) result = calculate_series_sum(n) print(f"Сумма первых {n} членов ряда: {result}")

Задача 2: Вывод графика

python
def print_graph(): pattern = [9, 3, 2, 1, 2, 3, 4, 5, 6] # Паттерн повторяющихся значений для графика for value in pattern: print("*" * value) print_graph()

Задача 3: Вывод шахматной доски

python
def print_chessboard(size): for i in range(size): for j in range(size): if (i + j) % 2 == 0: print("*", end="") else: print("#", end="") print() # Переход на новую строку после вывода каждой строки size = int(input("Введите размер шахматной доски: ")) print_chessboard(size)

Надеюсь, эти программы помогут вам выполнить задачи! Если у вас возникнут вопросы, не стесняйтесь задавать их.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос