Вопрос задан 04.07.2023 в 11:27.
Предмет Информатика.
Спрашивает Иванов Илья.
Дан массив B из 15 элементов целого типа. Написать программу по нахождению суммы и произведения
всех элементов массива. Паскаль. Заранее спасибо за помощь.Ответы на вопрос
Отвечает Серов Никита.
program sipcm;
uses
crt;
var
b: array [1..15] of integer;
var
i, s, pr: integer;
begin
s := 0;
pr := 1;
writeln('Заполните массив:');
for i := 1 to 15 do
begin
write('b[', i, '] = ');
readln(b[i]);
end;
for i := 1 to 15 do
begin
s := s + b[i];
pr := pr * b[i];
end;
writeln('Сумма: ', s, ' ; Произведение: ', pr);
readln;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример кода на языке Pascal, который находит сумму и произведение всех элементов массива:
pascalprogram ArraySumAndProduct; var B: array[1..15] of Integer; i, sum, product: Integer; begin // Заполнение массива B for i := 1 to 15 do begin Write('Введите элемент B[', i, ']: '); Readln(B[i]); end; // Инициализация переменных sum := 0; product := 1; // Нахождение суммы и произведения for i := 1 to 15 do begin sum := sum + B[i]; product := product * B[i]; end; // Вывод результатов Writeln('Сумма всех элементов: ', sum); Writeln('Произведение всех элементов: ', product); end.
Скопируйте этот код в свою среду разработки Pascal и запустите его. Программа попросит вас ввести 15 целых чисел, после чего выведет сумму и произведение всех элементов массива B.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
