
Вопрос задан 04.07.2023 в 01:12.
Предмет Информатика.
Спрашивает Безсмертний Саша.
1) Напишите программу, которое получает с клавиатуры пятизначное число и удаляет из негопервую и
последнюю цифру, например, из числа12345 должно получится 234.2) Напишите программу, которая получает склавиатуры значение катетов аи b прямоугольноготреугольника и вычисляет значение гипотенузыс, а затем выводит его на экран. (Использоватьформатный вывод. Вывести 2 знака послезапятой).

Ответы на вопрос

Отвечает Харламов Иван.
Ответ:
В чем сложность? ЯП: C++, переписать на любой другой не составит труда.
2)
#include <iostream>
#include <math.h>
int main() {
double katetA, katetB, gipotenuzaC;
std::cout << "Введите 2 катета треугольника: ";
std::cin >> katetA >> katetB;
gipotenuzaC = sqrt(katetA * katetA + katetB * katetB);
std::cout << gipotenuzaC;
return 0;
}
Объяснение:



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа 1: Удаление первой и последней цифры из пятизначного числа:
python# Получаем пятизначное число от пользователя
number = int(input("Введите пятизначное число: "))
# Проверяем, что число действительно пятизначное
if 10000 <= number <= 99999:
# Преобразуем число в строку, чтобы легче обрабатывать цифры
number_str = str(number)
# Удаляем первую и последнюю цифры, а затем преобразуем обратно в число
new_number = int(number_str[1:-1])
print("Результат:", new_number)
else:
print("Введите корректное пятизначное число.")
Программа 2: Вычисление гипотенузы прямоугольного треугольника:
pythonimport math
# Получаем значения катетов от пользователя
a = float(input("Введите значение катета a: "))
b = float(input("Введите значение катета b: "))
# Вычисляем гипотенузу
c = math.sqrt(a**2 + b**2)
# Выводим результат с округлением до 2 знаков после запятой
print(f"Гипотенуза: {c:.2f}")
Скопируйте каждую из этих программ в отдельный файл с расширением .py
и запустите их в вашей среде разработки, чтобы проверить их работоспособность.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili