Вопрос задан 03.07.2023 в 23:05.
Предмет Информатика.
Спрашивает Suhanova Asel.
ПАСКАЛЬ!!!!!!!!!!!!!!!!!!СРОЧНО!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!ПОМОГИТЕ
ПОЖАЛУЙСТА!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! Вычислить среднее арифметическое элементов числовой последовательности, в записи значения которых не содержится цифра 5. Если таких элементов не существует, то вывести 'NO'.Ответы на вопрос
Отвечает Лысенко Катя.
Какой массив???
??????????
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я помогу! Чтобы решить эту задачу, вам понадобится написать программу на языке программирования Паскаль. Вот пример кода, который решает данную задачу:
pascalprogram CalculateAverage; var n, count, sum, num: integer; hasDigit5: boolean; begin writeln('Введите количество элементов последовательности:'); readln(n); count := 0; sum := 0; writeln('Введите элементы последовательности:'); for var i := 1 to n do begin readln(num); // Проверяем, содержит ли число цифру 5 hasDigit5 := False; var temp := num; while temp > 0 do begin if temp mod 10 = 5 then begin hasDigit5 := True; break; end; temp := temp div 10; end; // Если число не содержит цифру 5, добавляем его к сумме if not hasDigit5 then begin sum := sum + num; count := count + 1; end; end; // Если не было элементов без цифры 5, выводим 'NO' if count = 0 then writeln('NO') else writeln('Среднее арифметическое: ', sum / count:0:2); end.
Программа запрашивает количество элементов в последовательности, затем вводит элементы и проверяет, содержит ли каждый элемент цифру 5. Если не содержит, то он добавляется к сумме, и в конце выводится среднее арифметическое только тех элементов, которые не содержат цифру 5. Если таких элементов нет, программа выведет 'NO'.
Похожие вопросы
Информатика 36
Информатика 77
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
