
ПАСКАЛЬ. Составить программу нахождения произведения цифр целого числа.


Ответы на вопрос

Ответ:
program comp;
var
number, composition, last_number: integer;
begin
composition := 1;
read(number);
while (number > 0) do
begin
last_number := number mod 10;
composition := composition * last_number;
number := number div 10;
end;
write(composition);
end.
Объяснение:
program comp; // Название программы
var
number, composition, last_number: integer; // Создание целочисланных переменных:
- number - число, которое вводится с клавиатуры;
- composition - переменная для хранения произведения цифр числа;
- last_number - переменная, которая будет хранить цифры числа.
begin // Начало программы
composition := 1; // Переменной composition присваиваем значение 1
read(number); // Считываем число с клавиатуры
while (number > 0) do // Пока переменная number > 0 выполняем
begin // Начало цикла
last_number := number mod 10; // Берем последнюю цифру от числа (остаток от деления на 10)
composition := composition * last_number; // В переменную composition записываем произведение переменной composition и переменной last_number
number := number div 10; // Отделяем последнюю цифру от числа (целочисленное деление на 10)
end; // Конец цикла
write(composition); // Вывод значения переменной composition
end. // Конец программы



Конечно, вот пример программы на языке Паскаль для нахождения произведения цифр целого числа:
pascalprogram MultiplyDigits; var num, product, digit: integer; begin // Вводим целое число writeln('Введите целое число:'); readln(num); // Инициализируем произведение единицей product := 1; // Пока число не станет равным 0 while num <> 0 do begin // Получаем последнюю цифру числа digit := num mod 10; // Умножаем текущее произведение на текущую цифру product := product * digit; // Убираем последнюю цифру из числа num := num div 10; end; // Выводим результат writeln('Произведение цифр числа: ', product); end.
Программа запрашивает у пользователя ввод целого числа и затем находит произведение всех его цифр. В цикле while мы извлекаем последнюю цифру числа с помощью операций деления и взятия остатка от деления на 10, затем умножаем текущее произведение на эту цифру и убираем последнюю цифру из числа путем целочисленного деления на 10.


Похожие вопросы
Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili