Вопрос задан 03.07.2023 в 01:43. Предмет Информатика. Спрашивает Коновалова Вика.

НА PYTHON: Написать программу, которая выводит ваш возраст в формате: "Вам XX ГОД/ГОДА/ЛЕТ"; нужно

чтоб было правильное слово именно, типа "года, год ,лет. БЕЗ СПАМА​
0 1
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Свищук Мирон.

age = int(input("Введите свой возраст: "))

if (age%10==1) and (age != 11) and (age != 111):

   print("Вам",age,"год")

elif (age%10>1) and (age%10<5) and (age!=12) and (age!=13) and (age!=14):

   print("Вам",age,"года")

else:

   print("Вам",age,"лет")

0 1
Отвечает Гришин Вова.

Ответ:

x=int(input())

   if x % 10 == 1 and x!=11 and x%100!=11:

       print('Вам', x, 'год')

   elif 1 < x % 10 <= 4 and x!=12 and x!=13 and x!=14:

       print('Вам', x, 'года')

   else:

       print('Вам', x, 'лет')

Объяснение:

Это проверка на то, какое слово пишем после числа лет:

1 год,

2 года,

3 года.

4 года,

5 лет,

6 лет,

7 лет,

8 лет,

9 лет,

10 лет,

11 лет,

12 лет,

13 лет,

14 лет,

15 лет,

16 лет,

17 лет,

18 лет,

19 лет,

20 лет,

21 год,

22 года,

23 года,

24 года,

25 лет,

26 лет,

27 лет,

28 лет,

29 лет,

30 лет,

...

если год при остатке деления на 100 дает 11, то лет

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Python, которая запрашивает год вашего рождения и выводит ваш возраст в правильной форме:

python
def get_age_suffix(age): if age % 10 == 1 and age % 100 != 11: return "год" elif 2 <= age % 10 <= 4 and (age % 100 < 10 or age % 100 >= 20): return "года" else: return "лет" def main(): current_year = 2023 # текущий год birth_year = int(input("Введите год вашего рождения: ")) age = current_year - birth_year age_suffix = get_age_suffix(age) print(f"Вам {age} {age_suffix}") if __name__ == "__main__": main()

Скопируйте этот код в файл с расширением .py, выполните его, и он попросит вас ввести год вашего рождения. После ввода вы получите ваш возраст в правильной форме.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос