ПОМОГИТЕ, ПОЖАЛУЙСТА ПРОГРАММИРОВАНИЕ 9 КЛАССНАПИШИТЕ ПРОГРАММУ В ПАСКАЛЕНа уроке физкультуры
тренер Андрей Сергеевич выстраивает учеников в одну шеренгу. При этом ученики в шеренге стоят по невозрастанию роста. Андрея Сергеевича заинтересовал вопрос, какое максимальное различие в росте двух стоящих рядом учеников. Напишите программу, которая поможет Андрею Сергеевичу ответить на этот важный для него вопрос.Формат входных данныхПервая строка содержит целое число n — число учеников в классе (2 ≤ n ≤ 20). Следующие n строк содержат по одному целому числу hi — рост в сантиметрах i-го ученика (100 ≤ hi ≤ 200).Формат выходных данныхВыведите одно число — максимальное различие в росте стоящих рядом учеников после того, как они выстроятся в шеренгу на уроке физкультуры.Примеры:Пример вводаПример вывода:612013014211514513410Ответы на вопрос
Ответ:
pascal
Объяснение:
program rost;
var
n, i, j, maxrazn: integer;
hi: array of integer;
begin
Write('Введите количество учеников: ');
ReadLn(n);
SetLength(hi, n);
WriteLn('Введите рост учеников:');
for i := 0 to n - 1 do
ReadLn(hi[i]);
for i := 0 to n - 2 do
for j:= i + 1 to n - 1 do
if hi[i] < hi[j] then swap(hi[i], hi[j]);
for i := 0 to n - 2 do
if hi[i] - hi[i + 1] > maxrazn then maxrazn := hi[i] - hi[i + 1];
WriteLn('Максимальное различие в росте стоящих рядом учеников равно ', maxrazn, ' см.');
end.
Конечно, я помогу вам написать программу на языке Паскаль для решения этой задачи. Вот пример кода:
pascalprogram MaxHeightDifference; var n, i, maxHeightDiff, height: integer; begin // Ввод количества учеников readln(n); // Инициализация максимального различия в росте maxHeightDiff := 0; // Считываем рост каждого ученика и находим максимальное различие for i := 1 to n do begin readln(height); if i > 1 then begin // Вычисляем различие в росте между текущим и предыдущим учеником if abs(height - prevHeight) > maxHeightDiff then maxHeightDiff := abs(height - prevHeight); end; prevHeight := height; // Сохраняем рост текущего ученика для следующей итерации end; writeln(maxHeightDiff); // Выводим максимальное различие в росте end.
Вы можете вставить этот код в вашу среду программирования для Паскаля и выполнить его. Программа сначала считывает количество учеников n, затем поочередно считывает рост каждого ученика и вычисляет максимальное различие в росте между стоящими рядом учениками. В конце выводится найденное максимальное различие в росте.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
