Вопрос задан 02.07.2023 в 09:41. Предмет Информатика. Спрашивает Валецкий Евгений.

Напишите программу, которая получает случайное натуральное число из отрезка [64; 511] и выводит на

экран запись этого числа в восьмеричной системе счисления. Оформите вывод так, как в примере: Случайное число 83 В восьмеричной системе 123 Язык python
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Жоламан Саит.

import random

def to8(x):

       new=''

       while x>0:

           new=str(x%8)+new

           x //= 8

       return(new)

a=random.randint(64,511)

print('Случайное число',a)

print('В восьмеричной системе',to8(a))

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на Python, которая выполняет указанную задачу:

python
import random # Генерация случайного числа из отрезка [64; 511] random_number = random.randint(64, 511) # Перевод числа в восьмеричную систему счисления octal_representation = oct(random_number)[2:] # Убираем префикс '0o' # Вывод результата print("Случайное число", random_number) print("В восьмеричной системе", octal_representation)

Программа использует библиотеку random для генерации случайного числа из заданного диапазона. Затем она использует встроенную функцию oct() для перевода числа в восьмеричную систему счисления. Выходное значение содержит префикс '0o', который убирается срезом [2:]. В конце программа выводит результаты в желаемом формате.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос