Вопрос задан 02.07.2023 в 05:24.
Предмет Информатика.
Спрашивает Бец Арина.
Pascal ABC. Составьте программу нахождения минимального элемента среди отрицательных чисел и
максимального элемента среди положительных.Ответы на вопрос
Отвечает Беркут Илья.
begin
var count := ReadInteger('Введите количество чисел:');
var min := 0;
var max := 0;
for var i := 1 to count do
begin
var number := ReadInteger('Введите число:');
if (number > 0) and (number > max) then max := number;
if (number < 0) and (number < min) then min := number;
end;
Println('Минимальное среди отрицательных:', min);
Println('Максимальное среди положительных:', max);
end.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Pascal ABC для нахождения минимального отрицательного элемента и максимального положительного элемента в массиве:
pascalprogram MinMaxElement; const N = 10; // Размер массива var arr: array[1..N] of Integer; i: Integer; minNegative, maxPositive: Integer; begin // Ввод элементов массива writeln('Введите элементы массива:'); for i := 1 to N do begin write('Элемент ', i, ': '); readln(arr[i]); end; // Инициализация переменных для минимального отрицательного и максимального положительного элементов minNegative := MaxInt; maxPositive := -MaxInt; // Поиск минимального отрицательного и максимального положительного элементов for i := 1 to N do begin if (arr[i] < 0) and (arr[i] < minNegative) then minNegative := arr[i]; if (arr[i] > 0) and (arr[i] > maxPositive) then maxPositive := arr[i]; end; // Вывод результатов writeln('Минимальный отрицательный элемент: ', minNegative); writeln('Максимальный положительный элемент: ', maxPositive); end.
Программа предполагает ввод 10 целых чисел пользователем и затем находит минимальное отрицательное и максимальное положительное число среди введенных элементов массива.
Похожие вопросы
Информатика 78
Информатика 94
Информатика 25
Информатика 28
Информатика 19
Информатика 26
Информатика 329
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
