
Написать программу на языке С. В числовом массиве найти сумму чисел, которые имеют одинаковые
знаки и расположены на одинаковом расстоянии от начала и конца массива (сумма пар чисел).

Ответы на вопрос

Ответ:
в фото
Объяснение:
#include <stdio.h>
#include <stdlib.h>
#define N 30
int main()
{
int massiv[N];
for(int i = 0; i < N; i ++)
{
massiv[i] = rand()%20 - 10;
printf("massiv[%i] = %i\n", i, massiv[i]);
}
for(int i = 0; i < N/2; i ++)
{
int element_naprotiv = N-1-i;
int znaki = (massiv[i]> 0) + (massiv[element_naprotiv] > 0);
if(znaki != 1)
printf("massiv[%i] = %i, massiv[%i] = %i, summa = %i\n", i, massiv[i], element_naprotiv, massiv[element_naprotiv], massiv[i] + massiv[element_naprotiv]);
}
return 0;
}




Конечно, вот пример программы на языке C, которая решает данную задачу:
c#include <stdio.h>
#include <stdlib.h>
int main() {
int n;
printf("Введите размер массива: ");
scanf("%d", &n);
if (n < 2) {
printf("Массив должен содержать хотя бы два элемента.\n");
return 1;
}
int arr[n];
printf("Введите элементы массива:\n");
for (int i = 0; i < n; i++) {
scanf("%d", &arr[i]);
}
int sum = 0;
int distance = n / 2; // Расстояние от начала и конца массива
for (int i = 0; i < distance; i++) {
if ((arr[i] > 0 && arr[n - 1 - i] > 0) || (arr[i] < 0 && arr[n - 1 - i] < 0)) {
sum += arr[i] + arr[n - 1 - i];
}
}
printf("Сумма чисел с одинаковыми знаками на одинаковом расстоянии от начала и конца: %d\n", sum);
return 0;
}
Эта программа сначала запрашивает размер массива, затем вводит элементы массива. После этого она проходит через массив и находит сумму чисел с одинаковыми знаками, расположенными на одинаковом расстоянии от начала и конца массива.


Похожие вопросы
Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili