Срочно Написать программу (паскаль), которая формирует новый массив С размера 7, каждый элемент
которого равен минимальному из элементов массивов А и В с тем же индексомОтветы на вопрос
Ответ:
Лови первую задачку! Остальные не знаю:с
var a: array[1..10] of integer; i,min: integer;
begin
for i:= 1 to 10 do
begin
writeln( 'a[',i,']=');
readln (a[i]);
end;
min:= 32687;
for i:= 1 to 10 do
if a[i]< min then min:= a[i];
writeln('min=',min);
end.
Объяснение:
Конечно, вот пример программы на языке Паскаль, которая выполняет указанную вами задачу:
pascalprogram MinArray; var A, B, C: array [1..7] of Integer; i: Integer; begin // Заполнение массивов A и B (по условию задачи) for i := 1 to 7 do begin // Здесь можно ввести значения элементов массивов A и B или сгенерировать их случайным образом // Пример ввода с клавиатуры: // Write('Введите элемент A[', i, ']: '); // Readln(A[i]); // Write('Введите элемент B[', i, ']: '); // Readln(B[i]); // Временно используем случайные числа для демонстрации A[i] := Random(100); B[i] := Random(100); end; // Формирование массива C for i := 1 to 7 do begin if A[i] < B[i] then C[i] := A[i] else C[i] := B[i]; end; // Вывод массива C Writeln('Массив C:'); for i := 1 to 7 do Write(C[i], ' '); end.
Этот код сначала заполняет массивы A и B значениями (в данном примере используются случайные числа), затем формирует массив C, в котором каждый элемент равен минимальному из соответствующих элементов массивов A и B. Наконец, выводится массив C.
Обратите внимание, что код предоставлен в качестве примера и может быть доработан согласно вашим потребностям, например, можно изменить способ ввода значений или генерации случайных чисел.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
