Вопрос задан 01.07.2023 в 20:44.
Предмет Информатика.
Спрашивает Загидуллин Ильмир.
Напишите программу, которая для заданного натурального числа N выведет квадраты всех целых чисел от
N до 1. C++Ответы на вопрос
Отвечает Теленченко Даниил.
#include <iostream>
using namespace std;
int main()
{
long long n;
cin >> n;
for(long long i = n; i >= 1; --i)
cout << i*i << ' ';
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на C++, которая выводит квадраты всех целых чисел от заданного натурального числа N до 1:
cpp#include <iostream>
int main() {
int N;
// Вводим значение N
std::cout << "Введите натуральное число N: ";
std::cin >> N;
// Проверка на корректность ввода
if (N <= 0) {
std::cout << "Введено некорректное значение N." << std::endl;
return 1;
}
// Выводим квадраты чисел от N до 1
for (int i = N; i >= 1; --i) {
int square = i * i;
std::cout << "Квадрат числа " << i << " равен " << square << std::endl;
}
return 0;
}
Вышеуказанная программа сначала запрашивает у пользователя натуральное число N, а затем выводит квадраты всех целых чисел от N до 1, включая N и 1.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
