Срочно! Помогите написать программу на языке С#. Дан массив размером nxm, элементы которого целые
числа. Подсчитать среднее арифметическое четных элементов, расположенных ниже главной диагонали.Ответы на вопрос
Ответ:
на локальных тестах работает
Объяснение:
using System;
class Program
{
static int P(string p)
{
int a = 0, dec = 1;
for (int i = p.Length - 1; i >= 0; i--)
{
a += (p[i] - '0') * dec;
dec *= 10;
}
return a;
}
static void Main(string[] args)
{
int n = int.Parse(Console.ReadLine());
int m = int.Parse(Console.ReadLine());
int c = 0, sum = 0;
for (int i = 0; i < n; i++)
{
int nowSum = 0;
string a = Console.ReadLine();
string[] now = a.Split(' ');
for (int j = 0; j < i; j++)
{
int num = P(now[j]);
if (num % 2 == 0)
{
c++;
sum += num;
}
}
}
Console.WriteLine(sum / c);
Console.ReadLine();
}
}
Конечно, вот пример программы на C#, которая решает задачу подсчета среднего арифметического четных элементов, расположенных ниже главной диагонали:
csharpusing System;
namespace ArrayAverage
{
class Program
{
static void Main(string[] args)
{
// Задайте размеры массива nxm
int n = 4; // количество строк
int m = 4; // количество столбцов
// Создайте и инициализируйте массив
int[,] array = new int[n, m]
{
{ 1, 2, 3, 4 },
{ 5, 6, 7, 8 },
{ 9, 10, 11, 12 },
{ 13, 14, 15, 16 }
};
// Переменные для подсчета суммы и количества четных элементов
int sum = 0;
int count = 0;
// Обход элементов ниже главной диагонали
for (int i = 1; i < n; i++)
{
for (int j = 0; j < i; j++)
{
if (array[i, j] % 2 == 0) // Проверка на четность
{
sum += array[i, j];
count++;
}
}
}
// Вычисление среднего арифметического
double average = (double)sum / count;
// Вывод результата
Console.WriteLine($"Среднее арифметическое четных элементов ниже главной диагонали: {average}");
}
}
}
Примечание:
- В этом примере предполагается, что массив уже задан с определенными значениями. Вы можете изменить значения в массиве
arrayв соответствии с вашей задачей. - Программа предполагает, что n >= 2, так как главная диагональ находится между элементами array[0,0] и array[1,1].
- Программа также предполагает, что в массиве есть четные элементы ниже главной диагонали. В противном случае, перед использованием переменной
count, стоит проверить, чтоcountбольше нуля, чтобы избежать деления на ноль при вычислении среднего арифметического.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
