1 Задан целочисленный одномерный массив а состоящий из n элементов. Написать программу подсчета
количества, суммы и произведения отрицательных элементов массива. 2 Перенести условие задачи 1 на использование двумерного массива а, размерности 3×3.C++Ответы на вопрос
Ответ:
1.
#include <iostream>
#define N 10
int main()
{
using namespace std;
int count = 0, sum = 0, mult = 1;
int arr[N]{0, 7, 5, 2, -10, -3, 4, 6, 12, -1};
for (const auto i : arr)
{
if (i < 0)
{
count++;
sum += i;
mult *= i;
}
}
cout << "Count = " << count << "\nSum = " << sum
<< "\nMult = " << mult;
return 0;
}
2.
#include <iostream>
#define N 3
int main()
{
using namespace std;
int count = 0, sum = 0, mult = 1;
int arr[N][N]{0, 7, 5, 2, -10, -3, 4, 6, -1};
for (int i = 0; i < N; i++)
{
for (int j = 0; j < N; j++)
{
if (arr[i][j] < 0)
{
count++;
sum += arr[i][j];
mult *= arr[i][j];
}
}
}
cout << "Count = " << count << "\nSum = " << sum
<< "\nMult = " << mult;
return 0;
}
Конечно, вот пример программы на языке C++ для решения обеих задач:
Задача 1: Работа с одномерным массивом
cpp#include <iostream>
int main() {
int n;
std::cout << "Введите размер массива: ";
std::cin >> n;
int* arr = new int[n];
std::cout << "Введите элементы массива:" << std::endl;
for (int i = 0; i < n; ++i) {
std::cin >> arr[i];
}
int countNegatives = 0;
int sumNegatives = 0;
int productNegatives = 1;
for (int i = 0; i < n; ++i) {
if (arr[i] < 0) {
++countNegatives;
sumNegatives += arr[i];
productNegatives *= arr[i];
}
}
std::cout << "Количество отрицательных элементов: " << countNegatives << std::endl;
std::cout << "Сумма отрицательных элементов: " << sumNegatives << std::endl;
std::cout << "Произведение отрицательных элементов: " << productNegatives << std::endl;
delete[] arr;
return 0;
}
Задача 2: Работа с двумерным массивом
cpp#include <iostream>
int main() {
const int rows = 3;
const int cols = 3;
int arr[rows][cols];
std::cout << "Введите элементы двумерного массива 3x3:" << std::endl;
for (int i = 0; i < rows; ++i) {
for (int j = 0; j < cols; ++j) {
std::cin >> arr[i][j];
}
}
int countNegatives = 0;
int sumNegatives = 0;
int productNegatives = 1;
for (int i = 0; i < rows; ++i) {
for (int j = 0; j < cols; ++j) {
if (arr[i][j] < 0) {
++countNegatives;
sumNegatives += arr[i][j];
productNegatives *= arr[i][j];
}
}
}
std::cout << "Количество отрицательных элементов: " << countNegatives << std::endl;
std::cout << "Сумма отрицательных элементов: " << sumNegatives << std::endl;
std::cout << "Произведение отрицательных элементов: " << productNegatives << std::endl;
return 0;
}
Оба примера позволят вам ввести элементы массива и вычислить количество, сумму и произведение отрицательных элементов.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
