На с ++, пожалуйста... На вход программы подается 10 чисел. Выведите в столбик для каждого из них
число, равное удвоенному квадрату первоначального числа.Ответы на вопрос
        Ответ:
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
double N[10];
cout << "vvedite 10 chisel" << endl;
for(int i=0;i<10;i++){
cin >> N[i];
}
for(int i=0;i<10;i++)
cout << pow(N[i],2) << endl;
system("pause");
return 0;
}
Объяснение:
        #include <iostream>
using namespace std;
int main() {
long long int arr[10] = {1,4,12,42,12,42,1,32,2213,74};
for(int i = 0; i<10; ++i) {
cout << arr[i]*arr[i]*2 << endl;
}
}
            Конечно, вот пример программы на C++, который выполняет описанное вами задание:
cpp#include <iostream>
int main() {
    const int count = 10; // Количество чисел
    int numbers[count];
    // Ввод чисел
    std::cout << "Введите " << count << " чисел:\n";
    for (int i = 0; i < count; ++i) {
        std::cin >> numbers[i];
    }
    // Вывод удвоенного квадрата для каждого числа
    std::cout << "Удвоенные квадраты чисел:\n";
    for (int i = 0; i < count; ++i) {
        int result = 2 * numbers[i] * numbers[i];
        std::cout << result << std::endl;
    }
    return 0;
}
Программа начинается с объявления массива numbers, в котором будут храниться введенные числа. Затем программа просит пользователя ввести 10 чисел и сохраняет их в массиве.
Далее идет цикл, который проходит по массиву чисел и для каждого числа вычисляет удвоенное значение квадрата и выводит его на экран.
Затем программа завершается, возвращая 0 в качестве кода завершения.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			