Дан массив 10 целых чисел, в диапазоне от 1 до 30. Найти произведение элементов массива, кратных 5.
Помогите написать программу! ПаскальОтветы на вопрос
Ответ
begin
ReadArrInteger(10).Where( x -> x mod 5 = 0).Product().Print();
end.
PascalABC.NET
Ответ:
begin
var mas := ArrRandomInteger(10, 1, 30);
mas.Println;
var composition := 1;
for var i := 0 to mas.Length - 1 do
begin
if (mas[i] mod 5 = 0) then
begin
composition := composition * mas[i];
end;
end;
write(composition);
end.
Объяснение:
begin // Начало программы
var mas := ArrRandomInteger(10, 1, 30); // Объявление массива размером 10 + заполнение массива случайными значениями из диапазона [1, 30].
mas.Println; // Вывод массива
var composition := 1; // Переменная, хранящая произведение чисел, которые делятся на 5 без остатка
for var i := 0 to mas.Length - 1 do // Идём от нуля до размера массива - 1
begin // Начало цикла
if (mas[i] mod 5 = 0) then // Если значение массива с индексом i делится на 5 без остатка
begin // Начало условного оператора
composition := composition * mas[i]; // Умножаем произведение на значение массива
end; // Конец условного оператора
end; // Конец цикла
write(composition); // Выводим ответ
end. // Конец программы
Конечно, вот пример программы на языке Паскаль для решения данной задачи:
pascalprogram MultiplyByFive; const N = 10; MinValue = 1; MaxValue = 30; var numbers: array[1..N] of Integer; i: Integer; product: LongInt; begin product := 1; // Заполнение массива случайными числами от 1 до 30 Randomize; for i := 1 to N do numbers[i] := Random(MaxValue - MinValue + 1) + MinValue; // Вывод исходного массива writeln('Исходный массив:'); for i := 1 to N do write(numbers[i], ' '); writeln; // Нахождение произведения элементов, кратных 5 for i := 1 to N do begin if (numbers[i] mod 5 = 0) then product := product * numbers[i]; end; // Вывод произведения writeln('Произведение элементов, кратных 5: ', product); end.
Эта программа создает массив из 10 целых чисел, заполняет его случайными числами в диапазоне от 1 до 30, а затем находит произведение элементов, кратных 5. Результат выводится на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
