Вопрос задан 30.06.2023 в 18:09. Предмет Информатика. Спрашивает Иванов Иван.

Напишите программу на питоне. С экрана вводятся два целых числа a и b (при этом обязательно a

< b). Выведите все нечетные числа от a (включительно) до b (не включительно).
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Баглаев Петя.

a,b = int(input()), int(input())

for i in range(a,b):

   print(i)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вы можете использовать цикл for в Python для вывода всех нечетных чисел от a до b-1. Вот простая программа, которая это делает:

python
# Ввод двух целых чисел a и b a = int(input("Введите целое число a: ")) b = int(input("Введите целое число b (b должно быть больше a): ")) # Проверка, что a меньше b if a >= b: print("a должно быть меньше b. Попробуйте снова.") else: # Используем цикл for для вывода нечетных чисел от a до b-1 for number in range(a, b): if number % 2 != 0: print(number)

Просто скопируйте этот код в вашу среду разработки Python или интерпретатор Python и запустите программу. Она попросит вас ввести значения a и b, а затем выведет все нечетные числа от a до b-1.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос