Вопрос задан 08.07.2018 в 01:10.
Предмет Информатика.
Спрашивает Савченко Маргарита.
Напишите программу на языке паскаль как найти корни квадратного уравнения ( ax+bx+c=0 ),при этом
использовав if then else со значениями дискрименанта D=0 D<0 b D>0Ответы на вопрос
Отвечает Тасимов Диас.
Var
a, b, c, D: real;
x1, x2: real;
begin
Write('Введите А:'); Readln(a);
Write('Введите B:'); Readln(b);
Write('Введите C:'); Readln(c);
D := sqr(b) - (4 * a * c);
if (D > 0) then
begin
x1 := (-b + sqrt(D)) / (2 * a);
x2 := (-b - sqrt(D)) / (2 * a);
Writeln('x1=', x1);
Writeln('x2=', x2); end else
if(d = 0) then
begin
x1 := b / (2 * a);
Write('x1=', x1, 'x2=', x1);
end else
writeln('Корней нет');
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
