Вопрос задан 30.06.2023 в 11:14. Предмет Информатика. Спрашивает Амиров Ильдар.

Написать программу в паскаль, суть следующая: Пользователь вводит 10 целых чисел.. Полученная

программа должна вывести на экран сумму только четных чисел. Пожалуйста помогите 100 баллов!!!!!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Демьянова Анастасия.

Ответ:

program Chernovik;

var a,i,s: integer;

begin

s:=0;

for i:=1 to 10 do

begin

write(i:2,' число: ');

readln(a);

if a mod 2 = 0 then s:=s+a

end;

write('Сумма чётных чисел: ',s)

end.

Объяснение:

Используем цикл с параметром (переменная i)

Вводим число (переменная a)

Если число чётное, то увеличиваем сумму (переменная s) на него

Выводим сумму

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на Pascal, которая считывает 10 целых чисел с клавиатуры и выводит сумму только четных чисел:

pascal
program SumOfEvenNumbers; var i, number, sum: integer; begin sum := 0; writeln('Введите 10 целых чисел:'); for i := 1 to 10 do begin write('Число ', i, ': '); readln(number); // Проверяем, является ли число четным if number mod 2 = 0 then sum := sum + number; end; writeln('Сумма четных чисел: ', sum); readln; end.

Просто скопируйте этот код в среду разработки Pascal и выполните программу. Она попросит вас ввести 10 целых чисел, а затем выведет сумму только четных чисел.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос