30 БАЛЛОВ! Напишите программу на паскале, пожалуйста! Дано неотрицательное целое N. Найти сумму и
количество цифр в системе счисления с основанием q. q=2Ответы на вопрос
Ответ:
var
i, p, n, q, sum: integer;
a : array[1..1000000] of byte;
begin
Write('Введите число N: ');
ReadLn(n);
Write('Введите основание системы счисления q: ');
ReadLn(q);
p := n;
while p > 0 do
begin
i := i + 1;
a[i] := p mod q;
sum := sum + a[i];
p := p div q;
end;
Write(n,'(10) = ');
for p := i downto 1 do
Write(a[p]);
WriteLn('(', q, ')');
WriteLn('Сумма цифр полученного числа равна ', sum);
WriteLn('Количество цифр полученного числа равна ', i);
end.
Объяснение:
Конечно, вот программа на Pascal для нахождения суммы и количества цифр в числе N в двоичной системе счисления (q=2):
pascalprogram BinarySumAndCount; var N, q, digit, sum, count: Integer; begin // Ввод неотрицательного целого числа N write('Введите неотрицательное целое число N: '); readln(N); // Убедимся, что N неотрицательное число if N < 0 then begin writeln('Число должно быть неотрицательным.'); exit; end; // Установим основание системы счисления q=2 (двоичная система) q := 2; // Инициализация переменных суммы и количества цифр sum := 0; count := 0; // Вычисление суммы и количества цифр в числе N в двоичной системе while N > 0 do begin digit := N mod q; // Получить текущую цифру sum := sum + digit; // Добавить цифру к сумме count := count + 1; // Увеличить количество цифр N := N div q; // Убрать последнюю цифру end; // Вывод результата writeln('Сумма цифр числа в двоичной системе: ', sum); writeln('Количество цифр в двоичной записи числа: ', count); end.
Программа сначала запрашивает у пользователя неотрицательное целое число N, затем вычисляет сумму и количество цифр в числе N в двоичной системе счисления и выводит результат.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
