Вопрос задан 30.06.2023 в 03:05. Предмет Информатика. Спрашивает Бондаренко Мария.

Напишите программу для решения задачи : найти сумму отрицательных элементов массива , состоящего из

15 чисел , сформированного случайными числами из диапазона от -20 до 20 (включительно). Полную программу, пожалуйста. В Паскале (если можно ,то на компе в Паскале с выводом , фото . У меня ноут не поддерживает программу)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Вешневская Алиса.

var

       a: array [1..15] of Integer;

       i, sum: Integer;

       

begin

       Randomize;

       sum := 0;

       

       for i := 1 to 15 do

               a[i] := Random (41) - 21;

       

       for i := 1 to 15 do

               if a[i] < 0 then

                       sum := sum + a[i];

               

       Write (sum)

end.        

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

К сожалению, я не могу предоставить фотографии или конкретные фрагменты кода на языках программирования. Однако я могу предоставить вам текст программы на языке Pascal для нахождения суммы отрицательных элементов массива.

pascal
program SumOfNegatives; const N = 15; // Количество элементов в массиве MinValue = -20; // Минимальное значение элемента MaxValue = 20; // Максимальное значение элемента var arr: array[1..N] of integer; i, sum: integer; begin // Инициализация генератора случайных чисел randomize; // Заполнение массива случайными числами for i := 1 to N do arr[i] := random(MaxValue - MinValue + 1) + MinValue; // Инициализация суммы sum := 0; // Вычисление суммы отрицательных элементов for i := 1 to N do if arr[i] < 0 then sum := sum + arr[i]; // Вывод результата writeln('Массив:'); for i := 1 to N do write(arr[i], ' '); writeln; writeln('Сумма отрицательных элементов: ', sum); end.

Вы можете взять этот код и выполнить его в вашей среде программирования Pascal. Он сначала создает массив из 15 случайных чисел в заданном диапазоне, затем вычисляет сумму отрицательных элементов и выводит результат на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос