 
Pascal или C/C++ решение. 1. Вычислите значение суммы 2,2+2,4+2,6+...+12,4 2. Напишите программу
защитой от введения недопустимых данных, спросите номер вашей группы (252), и напечатайте информацию о количестве студентов в группе (31) 0
        0
         0
        0
    Ответы на вопрос
 
        Как понял 2 так и написал :D
Ответ:
1.
#include <iostream>
using namespace std;
double i, sum;
int main()
{
for(i = 2.2; i <= 12.4; i+=0.2)
sum += i;
cout << sum << endl;
return 0;
}
2.
#include <iostream>
using namespace std;
double m, n;
int main()
{
while(cin >> n)
if(n > 99 && n < 1000)
{
while(cin >> m)
if(m > -1 && m < 100)
{
cout << "B auditori" << n << ", " << m << "studentov" << endl;
break;
}
}
return 0;
}
Объяснение:
 0
                    0
                     0
                    0
                 
        Второе нужно типо вывести информацию о том, сколько человек находится в группе?
 0
                    0
                     0
                    0
                 
            Для решения этой задачи вам потребуется написать программу на языке программирования Pascal или C/C++. Вот пример решения на языке C++:
cpp#include <iostream>
using namespace std;
int main() {
    int groupNumber;
    
    // Запрашиваем номер группы и проверяем его на корректность
    cout << "Введите номер вашей группы (252): ";
    cin >> groupNumber;
    
    if (groupNumber != 252) {
        cout << "Неправильный номер группы. Программа завершена." << endl;
        return 1; // Возвращаем код ошибки
    }
    
    // Если номер группы верный, выводим информацию о количестве студентов
    int numberOfStudents = 31;
    cout << "В группе " << groupNumber << " " << numberOfStudents << " студент(а)." << endl;
    
    // Вычисляем сумму
    double sum = 0;
    for (double i = 2.2; i <= 12.4; i += 0.2) {
        sum += i;
    }
    
    // Выводим сумму
    cout << "Сумма ряда: " << sum << endl;
    
    return 0; // Возвращаем успешный код завершения
}
Этот код сначала запрашивает номер группы и проверяет его на корректность. Если номер группы не совпадает с 252, программа завершает выполнение с кодом ошибки 1. Если номер группы верный, она выводит информацию о количестве студентов в группе и затем вычисляет сумму ряда и выводит ее.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			