Написать программу которая находит корни квадратного уравнения в т.ч. комплексные. Коэффициенты
уравнения вводить с консоли. Язык C++Ответы на вопрос
Ответ:
Как-то так, наверное
Объяснение:
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
double a, x, b, c, D;
cout<<"Введите a: "; cin >> a;
cout<<"Введите b: "; cin >> b;
cout<<"Введите c: "; cin >> c;
D = pow(b,2)-4*a*c;
if(D>0){
cout << "x1 = " << ((-1)*b+sqrt(D))/(2*a)<<endl;
cout << "x2 = " <<((-1)*b-sqrt(D))/(2*a)<<endl;
}
else if(D==0){
cout << "x = " << ((-1)*b)/(2*a)<<endl;
}
else{
D*=(-1);
cout<< "x1 = " << ((-1)*b)/(2*a) <<"+"<< (sqrt(D))/(2*a) << "*i" <<endl;
cout<< "x2 = " << ((-1)*b)/(2*a) <<"-"<< (sqrt(D))/(2*a) << "*i" <<endl;
}
return 0;
}
Вот пример программы на C++, которая находит корни квадратного уравнения, включая комплексные корни. Программа запрашивает у пользователя ввод коэффициентов квадратного уравнения и затем выводит корни:
cpp#include <iostream>
#include <cmath>
#include <complex>
using namespace std;
int main() {
double a, b, c;
cout << "Введите коэффициенты квадратного уравнения (ax^2 + bx + c = 0):" << endl;
cout << "a: ";
cin >> a;
cout << "b: ";
cin >> b;
cout << "c: ";
cin >> c;
// Вычисление дискриминанта
double discriminant = b * b - 4 * a * c;
if (discriminant > 0) {
// Два действительных корня
double root1 = (-b + sqrt(discriminant)) / (2 * a);
double root2 = (-b - sqrt(discriminant)) / (2 * a);
cout << "Два действительных корня:" << endl;
cout << "Корень 1: " << root1 << endl;
cout << "Корень 2: " << root2 << endl;
} else if (discriminant == 0) {
// Один действительный корень
double root = -b / (2 * a);
cout << "Один действительный корень:" << endl;
cout << "Корень: " << root << endl;
} else {
// Комплексные корни
complex<double> root1(-b / (2 * a), sqrt(-discriminant) / (2 * a));
complex<double> root2(-b / (2 * a), -sqrt(-discriminant) / (2 * a));
cout << "Два комплексных корня:" << endl;
cout << "Корень 1: " << root1 << endl;
cout << "Корень 2: " << root2 << endl;
}
return 0;
}
Просто скопируйте этот код в свою среду разработки C++ и выполните программу. Она запросит вас ввести коэффициенты a, b и c, и затем выведет корни уравнения.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
