Вопрос задан 29.06.2023 в 11:38. Предмет Информатика. Спрашивает Конюхов Лев.

Составьте программу вычисления суммы нечетных элементов массива В= [3, 4, 7, 9, 6, 3, 4]

(проверьте программу) Помогите пожалуйста срочно! ​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кравченко Екатерина.

B = [3, 4, 7, 9, 6, 3, 4]

s = 0

for i in range(len(B)):

   if B[i] % 2 != 0:

       s += B[i]

print(s)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Python для вычисления суммы нечетных элементов массива:

python
# Заданный массив B = [3, 4, 7, 9, 6, 3, 4] # Инициализируем переменную для хранения суммы нечетных элементов сумма_нечетных = 0 # Проходим по каждому элементу массива for элемент in B: # Проверяем, является ли элемент нечетным if элемент % 2 != 0: # Если элемент нечетный, добавляем его к сумме сумма_нечетных += элемент # Выводим сумму нечетных элементов print("Сумма нечетных элементов массива B равна:", сумма_нечетных)

Этот код пройдет по всем элементам массива B, проверит, является ли каждый элемент нечетным (проверкой деления на 2 с остатком) и, если элемент нечетный, добавит его к сумме. Наконец, он выведет сумму нечетных элементов.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос