Напишите программу, которая считает произведение элементов массива целых чисел. Сначала задается
целое число N = размер массива (он всегда меньше или равен 10), затем N целых чисел, каждая на отдельной строке. Вывести произведение. Ввод, вывод (readln, writeln). Пример ввод 3 2 2 5 Вывод 20Ответы на вопрос
Предоставлю 2 программы
1)var a: array [1..10] of integer;
i,n,s: integer;
begin
read(n);
s:=1
for i:=1 to n do readln(a[i]);
for i:=1 to n do s:=s*a[i];
write(s);
end.
2)var a: array [1..10] of integer;
i,n,s: integer;
begin
read(n);
s:=1
for i:=1 to n do begin readln(a[i]); s:=s*a[i]; end;
write(s);
end.
Для выполнения задачи, описанной вами, вы можете написать программу на языке Pascal, используя операторы readln и writeln. Вот пример такой программы:
pascalprogram MultiplyArrayElements; var N, i, product: integer; arr: array[1..10] of integer; begin // Ввод размера массива readln(N); // Ввод элементов массива for i := 1 to N do readln(arr[i]); // Инициализация переменной для хранения произведения product := 1; // Вычисление произведения элементов массива for i := 1 to N do product := product * arr[i]; // Вывод результата writeln(product); end.
Эта программа сначала считывает размер массива N, затем считывает N целых чисел в массив arr, вычисляет произведение элементов массива и выводит результат. Вы можете запустить эту программу в своей среде разработки Pascal или скомпилировать и выполнить ее, чтобы получить необходимый вывод.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
