
Паскаль 1-ая девочка купила 3 булочки за Б руб. коп. и 6 конфет за В руб. коп. 2-ая девочка
купила 5 булочек за Д руб.коп. и 4 конфеты за Г руб.коп. Написать программу,которая показывает сколько каждая из них заплатила и кто больше

Ответы на вопрос

var b,v,d,g,d1,d2:real;
begin
writeln('Б руб: ');
readln(b);
writeln('В руб: ');
readln(v);
writeln('Д руб: ');
readln(d);
writeln('Г руб: ');
readln(g);
if (3*b + 6*v) > (5*d + 4*g) then begin
writeln('1 девочка заплатила больше');
d1:=3*b+6*v;
d2:=5*d+4*g;
end
else
if (5*d + 4*g) > (3*b + 6*v) then begin
writeln('2 девочка заплатила больше');
d1:=3*b+6*v;
d2:=5*d+4*g;
end
else if (5*d + 4*g) = (3*b + 6*v) then begin
d1:=3*b+6*v;
d2:=5*d+4*g;
writeln('девочки заплатили одинаково');
end;
writeln;
writeln('1 девочка: ',d1,' руб');
writeln('2 девочка: ',d2,' руб');
end.




Вы можете написать программу на языке Pascal для решения этой задачи. Вот пример программы:
pascalprogram CalculateExpenses; var A, B, C, D: integer; TotalCost1, TotalCost2: real; begin // Ввод данных для первой девочки writeln('Введите стоимость 3 булочек для 1-ой девочки (в рублях и копейках): '); readln(A, B); writeln('Введите стоимость 6 конфет для 1-ой девочки (в рублях и копейках): '); readln(C, D); // Рассчитываем общую стоимость покупок для первой девочки TotalCost1 := (3 * A + B / 100) + (6 * C + D / 100); // Ввод данных для второй девочки writeln('Введите стоимость 5 булочек для 2-ой девочки (в рублях и копейках): '); readln(A, B); writeln('Введите стоимость 4 конфет для 2-ой девочки (в рублях и копейках): '); readln(C, D); // Рассчитываем общую стоимость покупок для второй девочки TotalCost2 := (5 * A + B / 100) + (4 * C + D / 100); // Выводим результаты writeln('1-ая девочка заплатила ', TotalCost1:0:2, ' руб.'); writeln('2-ая девочка заплатила ', TotalCost2:0:2, ' руб.'); // Сравниваем, кто заплатил больше if TotalCost1 > TotalCost2 then writeln('1-ая девочка заплатила больше.') else if TotalCost2 > TotalCost1 then writeln('2-ая девочка заплатила больше.') else writeln('Обе девочки заплатили одинаково.'); end.
Эта программа сначала запрашивает данные для первой девочки (стоимость булочек и конфет), затем для второй девочки, рассчитывает общую стоимость покупок для каждой девочки и выводит результаты, а также определяет, кто заплатил больше.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili