 
Вопрос задан 29.06.2023 в 02:43.
Предмет Информатика.
Спрашивает Смирнов Евгений.
Написать программу питон Драконы, как известно, воруют золото и драгоценности у людей, у эльфов,
у гномов – где и когда только могут – и стерегут свою добычу до конца жизни (а живут драконы фактически вечно, если только их не убьют), но никогда не попользуются даже самым дешевым колечком. Сами они сделать неспособны ровно ничего, даже не могут укрепить какую-нибудь разболтавшуюся чешуйку в своей броне. Напишите программу, которая определит, заинтересуется ли дракон тем, что перечислено в строке. Если там есть золото в любой форме (достаточно проверить корень золот) или то слово, которое будет введено во второй строке, то точно заинтересуется. Если таких строк меньше половины всех строк для проверки, то надо сообщить ОСТАНЕТСЯ ГНОМАМ, если нет, то ЗАБЕРЕТ ДРАКОН. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Антонова Алюша.
                
    Ответ:
Драконы, как известно, воруют золото и драгоценности у людей, у эльфов, у гномов — где и когда только могут — и стерегут свою добычу до конца жизни (а живут драконы практически вечно, если только их не убьют), но никогда не попользуются даже самым дешёвым колечком.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Для создания такой программы на Python, вы можете использовать следующий код:
pythondef dragon_interest(strings, keyword):
    count_interested = 0
    for string in strings:
        # Проверяем наличие золота в строке
        if 'золот' in string.lower():
            count_interested += 1
            continue
        
        # Проверяем наличие введенного ключевого слова в строке
        if keyword.lower() in string.lower():
            count_interested += 1
    if count_interested > len(strings) / 2:
        return "ЗАБЕРЕТ ДРАКОН"
    else:
        return "ОСТАНЕТСЯ ГНОМАМ"
# Пример использования
strings = [
    "У дракона нет интереса к этой строке",
    "Дракону нравится золото и драгоценности",
    "Дракон не замечает обычное кольцо",
    "Дракон спит в своей пещере"
]
keyword = input("Введите ключевое слово: ")
result = dragon_interest(strings, keyword)
print(result)
Этот код определяет интерес дракона к строкам на основе наличия слова "золото" в строке или введенного ключевого слова. Затем он сравнивает количество интересных строк с общим количеством строк и выводит соответствующий результат.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			