Вопрос задан 29.06.2023 в 01:07.
Предмет Информатика.
Спрашивает Фесан Катя.
1)Напишите программу,которая принимает от пользователя два целых числа,затем их складывает и
выводит результат. 2)Напишите программу (на Pascal или C++),которая выводит на экран 5 чисел,которые ввел пользователь и возводит их в квадрат.Ответы на вопрос
Отвечает Остроушко Маргарита.
PascalABC.NET 3.7+
Задание 1:
- ### Pr(RI+RI)
Задание 2:
- ### RAI(5).Sel(x → x**2).Pr


Отвечает Дейлид Мария.
var a,b:integer;
begin
read(a,b);
writeln(a+b);
end.
var a,i:integer;
begin
for i:=1 to 5 do begin
read(a);
a:=a*a;
write(a,' ');
end;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для написания программы, выполняющей задачи 1 и 2, предоставлю код на языке C++. Вы можете скомпилировать и запустить этот код на своем компьютере.
cpp#include <iostream>
using namespace std;
int main() {
// Задача 1: Сложение двух чисел
int num1, num2;
// Просим пользователя ввести два целых числа
cout << "Введите первое целое число: ";
cin >> num1;
cout << "Введите второе целое число: ";
cin >> num2;
// Выполняем сложение и выводим результат
int sum = num1 + num2;
cout << "Результат сложения: " << sum << endl;
// Задача 2: Возводим 5 чисел в квадрат
int numbers[5];
cout << "Введите 5 целых чисел: ";
for (int i = 0; i < 5; i++) {
cin >> numbers[i];
}
cout << "Квадраты введенных чисел: ";
for (int i = 0; i < 5; i++) {
int square = numbers[i] * numbers[i];
cout << square << " ";
}
cout << endl;
return 0;
}
Скопируйте этот код в файл с расширением .cpp, скомпилируйте его с помощью компилятора C++ (например, g++), и запустите полученный исполняемый файл. Программа сначала запросит у пользователя два числа, выполнит сложение и выведет результат, а затем запросит ввод 5 чисел и выведет их квадраты.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 22
Информатика 36
Информатика 60
Информатика 2166
Информатика 10
Информатика 571
Информатика 49
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
