Вопрос задан 28.06.2023 в 21:25.
Предмет Информатика.
Спрашивает Маскинсков Владислав.
Составить программу на С++ Создайте массив из 10 ячеек числа введите на клавиатуре от 1 до
10.Выполняя сортировку выбором.Ответы на вопрос
Отвечает Толкунова Настя.
#include <iostream>
using namespace std;
int main() {
int a[10],size=10,min,temp;
for (int i = 0; i < 10; i++) {
cin >> a[i];
}
for (int i = 0; i < size - 1; i++) {
min = i;
for (int j = i + 1; j < size; j++) {
if (a[j] < a[min]) {
min = j;
}
temp = a[i];
a[i] = a[min];
a[min] = temp;
}
}
for (int i = 0; i < 10; i++) {
cout << a[i] << " ";
}
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на C++, которая создает массив из 10 элементов, просит пользователя ввести числа от 1 до 10 и затем выполняет сортировку выбором:
cpp#include <iostream>
using namespace std;
int main() {
const int size = 10;
int arr[size];
// Ввод элементов массива от пользователя
cout << "Введите 10 чисел от 1 до 10:" << endl;
for (int i = 0; i < size; i++) {
do {
cout << "Элемент " << i + 1 << ": ";
cin >> arr[i];
} while (arr[i] < 1 || arr[i] > 10);
}
// Сортировка выбором
for (int i = 0; i < size - 1; i++) {
int minIndex = i;
for (int j = i + 1; j < size; j++) {
if (arr[j] < arr[minIndex]) {
minIndex = j;
}
}
if (minIndex != i) {
int temp = arr[i];
arr[i] = arr[minIndex];
arr[minIndex] = temp;
}
}
// Вывод отсортированного массива
cout << "Отсортированный массив:" << endl;
for (int i = 0; i < size; i++) {
cout << arr[i] << " ";
}
cout << endl;
return 0;
}
Эта программа сначала запрашивает у пользователя ввод 10 чисел от 1 до 10 и сохраняет их в массиве. Затем она выполняет сортировку выбором и выводит отсортированный массив.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
